Installiere Nvidia Treiber für Ubuntu – HowTo

Ein einfacher, quell-offener Treiber ohne 3D-Beschleunigung („nv“) ist bereits bei Ubuntu vorinstalliert. Es folgt eine Übersicht von Nvidia Treiber, welche für Ubuntu verführbar sind:

Treiber – Übersicht:

Hardy Heron (8.04):

  • nvidia-glx-new – für GeForce5/FX
  • nvidia-glx – für GeForce2 MX bis GeForce4
  • nvidia-glx-legacy – für Karten älter als 5 Jahre wie z.B. TNT, TNT2, TNT Ultra, GeForce und GeForce2 ohne MX

Ubuntu Intrepid (8.10):

  • nvidia-glx-96 – für GeForce2 MX bis GeForce 4
  • nvidia-glx-173 – für GeForce FX
  • nvidia-glx-177 – für GeForce 6 und neuer
  • nvidia-glx-180 – für GeForce 6 und neuer (intrepid-updates)
  • nvidia-glx-190 – für GeForce GT(S) und neuer
  • nvidia-glx-195 (Beta) – für GeForce GT(S) und neuer

Ubuntu Jaunty Jackalope (9.04):

  • nvidia-glx-96 – GeForce2 MX bis GeForce 4
  • nvidia-glx-173 – GeForce FX
  • nvidia-glx-180 – Ab GeForce 6
  • nvidia-glx-190 – für GeForce GT(S) und neuer
  • nvidia-glx-195 (Beta) – für GeForce GT(S) und neuer

Karmic Koala (9.10):

  • nvidia-glx-96: GeForce2 MX bis GeForce 4
  • nvidia-glx-173: GeForce FX
  • nvidia-glx-185: Ab GeForce 6
  • nvidia-glx-190 – für GeForce GT(S) und neuer
  • nvidia-glx-195 (Beta) – für GeForce GT(S) und neuer

Automatische Installation von den neusten Treibern:

Als erstes müssen eine Konsole öffnen und uns als root anmelden.

sudo su -

Bei Ubuntu => Karmic Koala (9.10) können wir die Quellen und Keys sehr bequem mit einem Befehl in unser System aufnehmen.

add-apt-repository ppa:nvidia-vdpau/ppa

Falls du noch eine frühere Version von Ubuntu verwendest, kannst du dies mit folgenden Befehlen bewerkstelligen.

echo 'deb http://ppa.launchpad.net/nvidia-vdpau/ppa/ubuntu UBUNTU_VERSION main' >> /etc/apt/sources.list
echo 'deb-src http://ppa.launchpad.net/nvidia-vdpau/ppa/ubuntu UBUNTU_VERSION main' >> /etc/apt/sources.list

Wenn es sich bei der Distribution um z.B. Ubuntu Intrepid Ibex handelt, ersetzt du „UBUNTU_VERSION“ durch „intrepid“ bzw. durch „hardy“ oder „jaunty“!!!

Strg + D
(logout)

Wie bereits zuvor erwähnt, benötigen wir nun noch den passenden Key vom Server, falls du die Quellen per Hand in die sources.list aufgenommen hast.

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys CEC06767

Ab hier geht es für alle Ubuntu Versionen weiter…

sudo apt-get update
sudo aptitude install linux-restricted-modules-$(uname -r)
sudo aptitude install nvidia-190-modaliases nvidia-glx-190

„System -> Systemverwaltung -> Hardware-Treiber“ (Hardy, Intrepid, Jaunty)

„System -> Systemverwaltung -> Verwaltung eingeschränkter Treiber“ (Gutsy, Feisty)

… und aktiviere dort den glx-190-Treiber.

Um gleich zu prüfen, ob der Treiber ordnungsgemäß funktioniert, laden wir das folgenden Shell-Skript herunter.

cd ~/Desktop/
wget http://blogage.de/files/9124/download -O compiz-check
chmod +x compiz-check

Falls du nach einen „reboot“ nicht den richtigen Treiber per „./compiz-check“ angezeigt bekommst, kannst du noch folgendes ausprobieren.

sudo nvidia-xconfig

In der Datei „/etc/X11/xorg.conf“ unter dem Punkt ‚Section „Device“‚ muss nun als ‚Driver „nvidia“‚ eingetragen sein. Zudem kann man das Logo von Nvidia an dieser Stelle auch deaktivieren, dazu musst du unter dem Punkt ‚Section „Device“‚ ‚Option „NoLogo“ „True“‚ einfügen.

…falls dies nach einen erneuten „reboot“ nicht geholfen hat, kannst du noch folgendes probieren

sudo echo 'nvidia' >> /etc/modules

Manuelle Installation von den neusten Treibern:

Falls bereits Treiber automatisch installiert wurden, müssen diese mit folgendem Kommando entfernt werden.

sudo aptitude remove nvidia-glx*

Anschließend müssen folgende Pakete ggf. noch installiert werden.

sudo aptitude install linux-restricted-modules-$(uname -r) build-essential xserver-xorg-dev libc6-i386 nvidia-xconfig

Nun laden wir uns den neusten Nvidia-Treiber herunter ->www.computerbase.de

z.B.:

cd /tmp
wget http://de.download.nvidia.com/XFree86/Linux-x86/190.53/NVIDIA-Linux-x86-190.53-pkg1.run

nun verlassen wir unsere Desktop-Umgebung und beenden diese, dafür wechseln wir zur Konsole …

ALT + STRG + F1

… und melden uns als root an und schalten den Desktop aus.

sudo /etc/init.d/gdm stop
cd /tmp
(bei GNOME)
sudo /etc/init.d/kdm stop

(bei KDE)

cd /tmp
sh NVIDIA-Linux-x86-190.53-pkg1.run
nvidia-xconfig

In der Datei „/etc/X11/xorg.conf“ unter dem Punkt ‚Section „Device“‚ muss nun als ‚Driver „nvidia“‚ eingetragen sein. Zudem kann man das Logo von Nvidia an dieser Stelle auch deaktivieren, dazu musst du unter dem Punkt ‚Section „Device“‚ ‚Option „NoLogo“ „True“‚ einfügen.

…falls dies nach einen „reboot“ nicht geholfen hat, kannst du noch folgendes probieren

sudo echo 'nvidia' >> /etc/modules

falls das „./compiz-check“ Skript noch immer ausgibt, dass du die 3D-Effekte nicht aktivieren kannst, obwohl der Treiber nun installiert sind, dann versuch noch folgendes…

sudo nvidia-xconfig --composite --render-accel --add-argb-glx-visuals

Adobe Flash Plugin 10 – 32bit & 64bit

Installation auf Ubuntu – 32-Bit:

Als erstes musst du dir auf der folgenden Seite das „deb“-File herunterladen …

get.adobe.com/de/flashplayer/

… oder dir dies direkt per wget herunterladen.

wget http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_10_linux.deb

Gegebenenfalls laufenden Firefox Prozesse beenden bzw. Firefox schließen …

killall -9 firefox

.. nun deinstallieren wir ggf. das bereits installierte flashplugin-Paket

sudo apt-get remove -y --purge flashplugin-nonfree gnash gnash-common mozilla-plugin-gnash swfdec-mozilla libflashsupport nspluginwrapper

Falls du bereits Versucht hast, Flash per Hand zu installiert, entfernen wir vorsorglich auch diese Dateien.

sudo rm -f /usr/lib/mozilla/plugins/*flash*
sudo rm -f ~/.mozilla/plugins/*flash*
sudo rm -f /usr/lib/firefox/plugins/*flash*
sudo rm -f /usr/lib/firefox-addons/plugins/*flash*
sudo rm -rfd /usr/lib/nspluginwrapper

Kommen wir endlich zur Installation vom „Flash Player“

sudo dpkg -i install_flash_player_10_linux.deb

Installation auf Ubuntu – 64-Bit:

Wer bereits Ubuntu 9.10 verwendet, sollte als erstes einmal versuchen den Flash-Player mittels folgendem Kommando zu installieren…

sudo aptitude install flashplugin-installer

… ansonsten kann man es mit folgendem Weg versuchen, töte ggf. laufenden Firefox Prozesse.

sudo killall -9 firefox

Download und installiere „Getlibs“

cd ~
wget http://frozenfox.freehostia.com/cappy/getlibs-all.deb
sudo dpkg -i getlibs-all.deb

nun deinstallieren wir ggf. das bereits installierte flashplugin-Paket

sudo apt-get remove -y --purge flashplugin-nonfree gnash gnash-common mozilla-plugin-gnash swfdec-mozilla libflashsupport nspluginwrapper

und falls wir bereits etwas per Hand installiert haben, entfernen wir dies auch

sudo rm -f /usr/lib/mozilla/plugins/*flash*
sudo rm -f ~/.mozilla/plugins/*flash*
sudo rm -f /usr/lib/firefox/plugins/*flash*
sudo rm -f /usr/lib/firefox-addons/plugins/*flash*
sudo rm -rfd /usr/lib/nspluginwrapper

Install ia32-libs und nspluginwrapper

sudo apt-get install ia32-libs nspluginwrapper

Extra libs install

sudo getlibs -p libcurl3
sudo getlibs -p libnss3-1d
sudo getlibs -p libnspr4-0d

Auf der folgenden Seite musst du dir das passende File herunterladen:

cd ~
wget http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_10_linux.tar.gz
tar zxvf install_flash_player_10_linux.tar.gz
sudo cp install_flash_player_10_linux/libflashplayer.so /usr/lib/mozilla/plugins/
rm -rf ~/install_flash_player_10_linux/
sudo nspluginwrapper -i /usr/lib/mozilla/plugins/libflashplayer.so

nun erstellen wir noch ein paar Links uns schon sind wir fertig

sudo ln -sf /usr/lib/nspluginwrapper/plugins/npwrapper.libflashplayer.so /usr/lib/mozilla/plugins/
sudo ln -sf /usr/lib/nspluginwrapper/plugins/npwrapper.libflashplayer.so /usr/lib/firefox-addons/plugins/

Fertig!

Alternativ kann man dies auch mit folgendem Skript ausführen….

das folgende Skript herunterladen z.B. mit „wget“ oder einem Browser deinere Wahl

wget http://voku-online.de/flash10_en.sh

dieser Datei nun Ausführrechte geben

chmod +x flash10_en.sh

und ausführen…

sudo sh ./flash10_en.sh